2.2.4 Notificación de actualizaciones

Atención

El paquete apticron depende de la instalación de un agente de transporte de e-mail o MTA (Mail Transfer Agent). Por tanto, es necesario instalar primero un Servidor SMTP antes de proceder a la instalación de apticron.

Para garantizar que un sistema se actualice, lo mejor es estar informado de las actualizaciones disponibles. Apticron es un programa que se ejecuta diariamente de forma automática, y comprueba si hay actualizaciones disponibles para nuestro sistema, y luego informa al administrador del sistema por e-mail.

[email protected]:~# apt-get install apticron

Siempre que haya una actualización disponible para el sistema, se enviará un e-mail al administrador del sistema:

Date: Wed, 29 May 2013 21:06:09 +0100
To: [email protected]
Subject: 1 Debian package update(s) for server
From: [email protected] (root)

apticron report [Wed, 29 May 2013 21:06:08 +0100]
========================================================================

apticron has detected that some packages need upgrading on:

        server 
        [ 192.168.1.100]

The following packages are currently pending an upgrade:

        libgnutls26 2.12.20-7

========================================================================

Package Details:

Reading changelogs...
--- Changes for gnutls26 (libgnutls26) ---
gnutls26 (2.12.20-7) wheezy-security; urgency=high

  * [36_sanitycheck.diff] from upstream GIT. - Fix out of bounds data access.
    Closes: #709301

 -- Andreas Metzler <[email protected]>  Fri, 24 May 2013 19:54:10 +0200

========================================================================

You can perform the upgrade by issuing the command:

        apt-get dist-upgrade

as root on server

--
apticron 

Entonces, el administrador podrá actualizar el sistema con el comando apt-get dist-upgrade.

  • es/jessie/config/software/apticron.txt
  • Última modificación: 2020-08-02 20:10
  • (editor externo)